Apache 2.2 a PHP 4.4.0 – 4.4.7

Minule jsem tady psal jak nainstalovat Apache 2.2, PHP 5.2 a MySQL 5.1 na Windows Vista. V té době jsem ještě netušil, že se do oficiální distrubuce PHP 4.4.7 nedostal modul php4apache2_2.dll, který je potřeba ke komunikaci s Apache 2.2, protože nový Apache 2.2 má předělané API. Zkrátka podpora PHP4 se nám nějak stále více a více uzavírá a nutí nás přejít na mnohem lepší PHP5 a v budoucnu na PHP6. Jenže stále existuje hodně projektů, které jsou psány pro PHP4 a zatím není důvod migrovat na novější PHP. V praxi by to totiž byly akorát vyhozené peníze. Ale abych se dostal k řešení, které samozřejmě existuje, protože PHP4 má mnoho příznivců.

Stačí si potřebný soubor stáhnout ze stránek http://www.apachelounge.com/download/ konkrétně php4apache2.dll-php4.4.x.zip. Dále stačí postupovat podle přiloženého readme. Vše zase funguje tak jak má.



Komentáře

Zatím nikdo nepřidal komentář, můžete být první.



O autorovi

Pari

Vítejte na mém blogu, rád bych se v krátkosti představil. Je mi 26 let. Momentálně nejvíce času věnuji projektu Lepime.cz - obchod se samolepkami na zeď a tvorbě webů postavených na redakčním systému Drupal pod značkou MEPA.CZ.